首页 关于我们 成功案例 网站建设 电商设计 新闻中心 联系上品
QQ联系
电话联系
手机联系
QQ联系
电话联系
手机联系

LNMP一键安装包 V1.7 正式版发布 一键构建服务器环境

发布时间:2020-06-10 07:09
发布者:admin

LNMP一键安装包 v1.7主要增加支持PHP 7.4、增加Mariadb 10.4选项并移除MariaDB 10.0、增加systemd service脚本、增加多PHP版本升级工具 ./upgrade.sh mphp、优化lnmp管理脚本、完善CentOS8等新版本的支持。

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian/Deepin/Aliyun/Amazon/Mint Linux VPS或独立主机安装LNMP(Nginx/MySQL/PHP)、LNMPA(Nginx/MySQL/PHP/Apache)、LAMP(Apache/MySQL/PHP)生产环境的Shell程序。支持自定义Nginx、PHP编译参数及网站和数据库目录、支持生成LetseEcrypt证书、LNMP模式支持多PHP版本、支持单独安装Nginx/MySQL/MariaDB/Pureftpd服务器,同时提供一些实用的辅助工具如:虚拟主机管理、FTP用户管理、Nginx、MySQL/MariaDB、PHP的升级、常用缓存组件Redis/Xcache等的安装、重置MySQL root密码、502自动重启、日志切割、SSH防护DenyHosts/Fail2Ban、备份等许多实用脚本。

安装前建议使用screen,执行:screen -S lnmp?后,执行:wget http://soft.vpser.net/lnmp/lnmp1.7.tar.gz -cO lnmp1.7.tar.gz tar zxf lnmp1.7.tar.gz cd lnmp1.7 ./install.sh lnmp?请注意最后面的lnmp参数,如需要lnmpa 或 lamp 模式,请替换lnmp为你要安装的模式。

注意:目前新发布的CentOS 8、Ubuntu 20.04、Deepin 15.7+等请使用1.7进行安装,PHP 7.4依赖版本要求也比较高所以尽量选择CentOS 8+,Debian 8+,Ubuntu 16.04+这些Linux版本。

PHP 7.1.*以下版本不支持Ubuntu 19+、Debian 10等等非常新的Linux发行版!各项注意都在安装要求安装要求上有说明。

一句话就是不要在非常新的Linux发行版上安装老旧的程序,也不要在老旧的Linux发行版上安装非常新的各类程序,简而言之别老牛吃嫩草,嫩草也别让老牛给拱了。

增加多PHP版本升级工具 ./upgrade.sh mphp,只支持7.2.x-7.2.x类似小版本升级,大版本直接新装即可;

LNMP各个程序的状态管理:lnmp {nginx|mysql|mariadb|php-fpm|pureftpd} {start|stop|reload|restart|kill|status}

目前1.6版本与1.7版本编译参数、管理脚本方面相差很小。一般只需要 upgrade1.x-1.7.sh 升级一下管理脚本;如果想使用PHP 7.4的话,需要下载lnmp 1.7,使用升级脚本升级PHP。

eAccelerator,xcache,memcached,imageMagick,ionCube、opcache、redis的安装:https://lnmp.org/faq/addons.html